>_Skillful
Need help with advanced AI agent engineering?Contact FirmAdapt
Lovell Fuller

Lovell Fuller

@lovell

London, UK lovell.info On GitHub since February 2010

20

Published Tools

33,922

Total Stars

64,091,646

Weekly Downloads

1,759

GitHub Followers

77

Public Repos

Published Tools

20 Skillsacross 2 categories

GitHub Actions

High performance Node.js image processing, the fastest module to resize JPEG, PNG, WebP, GIF, AVIF and TIFF images

SkillComputer Vision
32K63.8M/wk1 dir

GitHub Actions

Node.js module to generate URL slugs. Another one? This one cares about i18n and transliterates non-Latin scripts to conform to the RFC3986 standard. Mostly API-compatible with similar modules.

...more
SkillAI Tool
6061 dir

GitHub Actions

Node-API implementation of FarmHash, Google's family of very fast hash functions

SkillAI Tool
453201K/wk1 dir

lovell

Command line utility to convert images to AVIF

SkillAI Tool
2261 dir

Node.js implementation of HighwayHash, Google's fast and strong hash function

SkillAI Tool
2221 dir

A small EXIF image metadata reader

SkillAI Tool
17199K/wk1 dir

GitHub Actions

Node.js module to detect the C standard library (libc) implementation family and version

SkillAI Tool
751 dir

lovell

Parse International Color Consortium (ICC) profiles

SkillAI Tool
591 dir

lovell

Detect the dominant palette, salient region and focal point of an image

SkillAI Tool
571 dir

GitHub Actions

Parse and validate RFC6838/RFC9694 media types, anything from 'text/plain' to 'application/vnd.company.app.entity-v2+xml;charset=utf8'

...more
SkillAI Tool
1926K/wk1 dir

GitHub Actions

Prebuilt sharp for use with Linux (glibc) x64

SkillAI Tool
1 dir

Prebuilt sharp for use with Linux (glibc) 64-bit ARM

SkillAI Tool
1 dir

Prebuilt sharp for use with Linux (musl) 64-bit ARM

SkillAI Tool
1 dir

Prebuilt sharp for use with macOS 64-bit ARM

SkillAI Tool
1 dir

GitHub Actions

Prebuilt sharp for use with macOS x64

SkillAI Tool
1 dir

Prebuilt sharp for use with Linux (glibc) s390x

SkillAI Tool
1 dir

GitHub Actions

Prebuilt sharp for use with Linux (glibc) ARM (32-bit)

SkillAI Tool
1 dir

Prebuilt sharp for use with Linux (glibc) ppc64

SkillAI Tool
1 dir

Prebuilt sharp for use with Linux (glibc) RISC-V 64-bit

SkillAI Tool
1 dir

Prebuilt libvips and dependencies for use with sharp on Linux (glibc) x64

SkillAI Tool
1 dir