18
Published Tools
1,804
Total Stars
24,945,542
Weekly Downloads
93
GitHub Followers
80
Public Repos
Published Tools
18 Skillsacross 3 categoriesmicroshine
Public Key Infrastructure (PKI) is the basis of how identity and key management is performed on the web today. PKIjs is a pure JavaScript library implementing the formats that are used in PKI applications. It is built on WebCrypto and aspires to make it p
...moremicroshine
asn1js is a pure JavaScript library implementing this standard. ASN.1 is the basis of all X.509 related data structures and numerous other protocols used on the web
...moremicroshine
ByteStream is a library making possible to manipulates single bytes and bits on pure JavaScript
microshine
ASN.1 schema of `Elliptic Curve Private Key Structure` (RFC5915)
microshine
ASN.1 schema of `RSA Cryptography Specifications Version 2.2` (RFC8017)
microshine
ASN.1 schema of `Public-Key Cryptography Standards (PKCS) #8: Private-Key Information Syntax Specification Version 1.2` (RFC5208)
...moremicroshine
ASN.1 schema of `PKCS #12: Personal Information Exchange Syntax v1.1` (RFC7292)
microshine
ASN.1 schema of `PKCS #10: Certification Request Syntax Specification Version 1.7` (RFC2986)
microshine
ASN.1 schema of `Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile` (RFC5280)
...moremicroshine
ASN.1 schema of `Internet X.509 Public Key Infrastructure: Logotypes in X.509 Certificates` (RFC3709)
GitHub Actions
ASN.1 schema for asymmetric key packages and OneAsymmetricKey structures defined in RFC 5958.
GitHub Actions
ASN.1 schema for composite public keys, private keys, and signatures for post-quantum Internet PKI drafts.
chiefmikey
ASN.1 schema for Cryptographic Message Syntax (CMS) defined in RFC 5652. (with updated dependencies)
phanmn
GammaCV is a WebGL accelerated Computer Vision library for browser
microshine
Core functionality library for PDF document processing and manipulation
GitHub Actions
Modern byte, encoding, integer, converter registry, and PEM utilities for TypeScript projects.
microshine
A foundational library for working with XML in JavaScript/TypeScript with schema validation through decorators